Skip to main content
← All vulnerabilities
CVE-2024-23321GHSA-Q9W2-H4CW-8GHP

Apache RocketMQ: Unauthorized Exposure of Sensitive Data

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.3.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

For RocketMQ versions 5.2.0 and below, under certain conditions, there is a risk of exposure of sensitive Information to an unauthorized actor even if RocketMQ is enabled with authentication and authorization functions. An attacker, possessing regular user privileges or listed in the IP whitelist, could potentially acquire the administrator's account and password through specific interfaces. Such an action would grant them full control over RocketMQ, provided they have access to the broker IP address list. To mitigate these security threats, it is strongly advised that users upgrade to version 5.3.0 or newer. Additionally, we recommend users to use RocketMQ ACL 2.0 instead of the original RocketMQ ACL when upgrading to version Apache RocketMQ 5.3.0.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • org.apache.rocketmq:rocketmq-broker

    From 4.5.2 · through 5.2.0

  • org.apache.rocketmq:rocketmq-allMaven

    From 4.5.2 · fixed in 5.3.0

References 2

lists.apache.org

openwall.com