Skip to main content
← All vulnerabilities
CVE-2024-23114GHSA-M43P-55RF-8C2J

Apache Camel: Camel-CassandraQL: Unsafe Deserialization from CassandraAggregationRepository

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.21.4, 3.22.1, 4.0.4, 4.4.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Deserialization of Untrusted Data vulnerability in Apache Camel CassandraQL Component AggregationRepository which is vulnerable to unsafe deserialization. Under specific conditions it is possible to deserialize malicious payload.This issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Apache Software Foundation Apache Camel

    From 3.0.0 · fixed in 3.21.4; From 3.22.0 · fixed in 3.22.1; From 4.0.0 · fixed in 4.0.4; From 4.1.0 · fixed in 4.4.0

  • org.apache.camel:camel-cassandraqlMaven

    From 3.0.0 · fixed in 3.21.4

  • org.apache.camel:camel-cassandraqlMaven

    From 3.22.0 · fixed in 3.22.1

  • org.apache.camel:camel-cassandraqlMaven

    From 4.0.0 · fixed in 4.0.4

  • org.apache.camel:camel-cassandraqlMaven

    From 4.1.0 · fixed in 4.4.0

References 1

camel.apache.org