Skip to main content
← All vulnerabilities
CVE-2024-22399GHSA-3XQ2-W6J4-C99R

Apache Seata: Remote Code Execution vulnerability via Hessian Deserialization in Apache Seata Server

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.1.0, 1.8.1
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Deserialization of Untrusted Data vulnerability in Apache Seata.  When developers disable authentication on the Seata-Server and do not use the Seata client SDK dependencies, they may construct uncontrolled serialized malicious requests by directly sending bytecode based on the Seata private protocol. This issue affects Apache Seata: 2.0.0, from 1.0.0 through 1.8.0. Users are recommended to upgrade to version 2.1.0/1.8.1, which fixes the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • io.seata:seata-all

    From 1.0.0 · through 1.8.0

  • org.apache.seata:seata-coreMaven

    From 2.0.0 · fixed in 2.1.0

  • org.apache.seata:seata-coreMaven

    From 1.0.0 · fixed in 1.8.1

References 1

lists.apache.org