Skip to main content
← All vulnerabilities
CVE-2024-22369GHSA-36XR-4X2F-CFJ9

Apache Camel: Camel-SQL: Unsafe Deserialization from JDBCAggregationRepository

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 3.21.4, 3.22.1, 4.0.4, 4.4.0
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Deserialization of Untrusted Data vulnerability in Apache Camel SQL ComponentThis issue affects Apache Camel: from 3.0.0 before 3.21.4, from 3.22.0 before 3.22.1, from 4.0.0 before 4.0.4, from 4.1.0 before 4.4.0. Users are recommended to upgrade to version 4.4.0, which fixes the issue. If users are on the 4.0.x LTS releases stream, then they are suggested to upgrade to 4.0.4. If users are on 3.x, they are suggested to move to 3.21.4 or 3.22.1

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • org.apache.camel:camel-sql

    From 3.0.0 · fixed in 3.21.4; From 3.22.0 · fixed in 3.22.1; From 4.0.0 · fixed in 4.0.4; From 4.1.0 · fixed in 4.4.0

  • org.apache.camel:camel-sqlMaven

    From 3.0.0 · fixed in 3.21.4

  • org.apache.camel:camel-sqlMaven

    From 3.22.0 · fixed in 3.22.1

  • org.apache.camel:camel-sqlMaven

    From 4.0.0 · fixed in 4.0.4

  • org.apache.camel:camel-sqlMaven

    From 4.1.0 · fixed in 4.4.0

References 2

lists.apache.org

GitHub · oscerd/CVE-2024-22369