Skip to main content
← All vulnerabilities
CVE-2024-22258GHSA-X637-X8P3-5P22

CVE-2024-22258: PKCE Downgrade in Spring Authorization Server

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.0.6, 1.1.6, 1.2.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Spring Authorization Server versions 1.0.0 - 1.0.5, 1.1.0 - 1.1.5, 1.2.0 - 1.2.2 and older unsupported versions are susceptible to a PKCE Downgrade Attack for Confidential Clients. Specifically, an application is vulnerable when a Confidential Client uses PKCE for the Authorization Code Grant. An application is not vulnerable when a Public Client uses PKCE for the Authorization Code Grant.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated

Affected versions

  • Spring Authorization Server

    From 1.0.x · fixed in 1.0.6; From 1.1.x · fixed in 1.1.6; From 1.2.x · fixed in 1.2.3

  • org.springframework.security:spring-security-oauth2-authorization-serverMaven

    fixed in 1.1.6

  • org.springframework.security:spring-security-oauth2-authorization-serverMaven

    From 1.2.0 · fixed in 1.2.3

References 1

spring.io