Skip to main content
← All vulnerabilities
CVE-2024-22257GHSA-F3JH-QVM4-MG39

In Spring Security, versions 5.7.x prior to 5.7.12, 5.8.x prior to 5.8.11, versions 6.0.x prior to 6.0.9, versions 6.1.x prior to 6.1.8, v

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 5.7.12, 5.8.11, 6.1.8, 6.2.3
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: partial

Summary

In Spring Security, versions 5.7.x prior to 5.7.12, 5.8.x prior to 5.8.11, versions 6.0.x prior to 6.0.9, versions 6.1.x prior to 6.1.8, versions 6.2.x prior to 6.2.3, an application is possible vulnerable to broken access control when it directly uses the AuthenticatedVoter#vote passing a null Authentication parameter.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • N/A Spring Security

    Version range not reported

  • org.springframework.security:spring-security-coreMaven

    fixed in 5.7.12

  • org.springframework.security:spring-security-coreMaven

    From 5.8.0 · fixed in 5.8.11

  • org.springframework.security:spring-security-coreMaven

    From 6.0.0 · fixed in 6.1.8

  • org.springframework.security:spring-security-coreMaven

    From 6.2.0 · fixed in 6.2.3

References 2

spring.io

security.netapp.com