Skip to main content
← All vulnerabilities
CVE-2024-22188GHSA-5W2H-59J3-8X5W

TYPO3 before 13.0.1 allows an authenticated admin user (with system maintainer privileges) to execute arbitrary shell commands (with the pri

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 8.7.57, 9.5.46, 10.4.43, 11.5.35, 12.4.11, and 1 more
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

TYPO3 before 13.0.1 allows an authenticated admin user (with system maintainer privileges) to execute arbitrary shell commands (with the privileges of the web server) via a command injection vulnerability in form fields of the Install Tool. The fixed versions are 8.7.57 ELTS, 9.5.46 ELTS, 10.4.43 ELTS, 11.5.35 LTS, 12.4.11 LTS, and 13.0.1.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • n/a n/a

    Version range not reported

  • typo3/cms-corePackagist

    From 8.0.0 · fixed in 8.7.57

  • typo3/cms-corePackagist

    From 9.0.0 · fixed in 9.5.46

  • typo3/cms-corePackagist

    From 10.0.0 · fixed in 10.4.43

  • typo3/cms-corePackagist

    From 11.0.0 · fixed in 11.5.35

  • typo3/cms-corePackagist

    From 12.0.0 · fixed in 12.4.11

  • typo3/cms-corePackagist

    From 13.0.0 · fixed in 13.0.1

References 2

typo3.org

GitHub · TYPO3/typo3