Skip to main content
← All vulnerabilities
CVE-2024-21733GHSA-F4QF-M5GF-8JM8BIT-TOMCAT-2024-21733

Apache Tomcat: Leaking of unrelated request bodies in default error page

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 9.0.44, 8.5.64
1 proof of concept on GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: partial

Summary

Generation of Error Message Containing Sensitive Information vulnerability in Apache Tomcat.This issue affects Apache Tomcat: from 8.5.7 through 8.5.63, from 9.0.0-M11 through 9.0.43. Other, EOL versions may also be affected. Users are recommended to upgrade to version 8.5.64 onwards or 9.0.44 onwards, which contain a fix for the issue.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: partial

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • Apache Software Foundation Apache Tomcat

    From 8.5.7 · through 8.5.63; From 9.0.0-M11 · through 9.0.43

  • org.apache.tomcat:tomcat-coyoteMaven

    From 9.0.0-M11 · fixed in 9.0.44

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 8.5.7 · fixed in 8.5.64

  • org.apache.tomcat.embed:tomcat-embed-coreMaven

    From 9.0.0-M11 · fixed in 9.0.44

  • org.apache.tomcat:tomcat-coyoteMaven

    From 8.5.7 · fixed in 8.5.64

  • org.apache.tomcat.experimental:tomcat-embed-programmaticMaven

    From 9.0.43 · fixed in 9.0.44

References 2

lists.apache.org

GitHub · LtmThink/CVE-2024-21733