Skip to main content
← All vulnerabilities
CVE-2024-21538GHSA-3XGQ-45JJ-V275

Versions of the package cross-spawn before 6.0.6, from 7.0.0 and before 7.0.5 are vulnerable to Regular Expression Denial of Service (ReDoS)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 6.0.6, 7.0.5, 7.0.6
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: yes
  • Technical impact: partial

Summary

Versions of the package cross-spawn before 6.0.6, from 7.0.0 and before 7.0.5 are vulnerable to Regular Expression Denial of Service (ReDoS) due to improper input sanitization. An attacker can increase the CPU usage and crash the program by crafting a very large and well crafted string.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: yes · Technical impact: partial

  3. Record last updated

Affected versions

  • n/a cross-spawn

    fixed in 6.0.6; From 7.0.0 · fixed in 7.0.5

  • n/a org.webjars.npm:cross-spawn

    fixed in 6.0.6; From 7.0.2 · fixed in 7.0.6

  • cross-spawnnpm

    From 7.0.0 · fixed in 7.0.5

  • cross-spawnnpm

    fixed in 6.0.6

References 5

security.snyk.io

GitHub · moxystudio/node-cross-spawn