Skip to main content
← All vulnerabilities
CVE-2024-20758GHSA-WH4M-6RH3-P4RQBIT-MAGENTO-2024-20758

Adobe Commerce | Improper Input Validation (CWE-20)

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.7, 2.4.6-p5, 2.4.5-p7, 2.4.4-p8
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.6-p4, 2.4.5-p6, 2.4.4-p7, 2.4.7-beta3 and earlier are affected by an Improper Input Validation vulnerability that could result in arbitrary code execution on the underlying filesystem. Exploitation of this issue does not require user interaction, but the attack complexity is high.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.7-beta3

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

  • magento/community-editionPackagist

    From 2.4.7-beta1 · fixed in 2.4.7

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p5

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p7

  • magento/community-editionPackagist

    From 2.4.4-p1 · fixed in 2.4.4-p8

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com