Skip to main content
← All vulnerabilities
CVE-2024-20720GHSA-525F-PVJ5-VQMQ

Command injection in data collector backup due to insufficient patching of CVE-2023-38208

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 2.4.6-p4, 2.4.5-p6, 2.4.4-p7
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: no
  • Technical impact: total

Summary

Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by an Improper Neutralization of Special Elements used in an OS Command ('OS Command Injection') vulnerability that could lead in arbitrary code execution by an attacker. Exploitation of this issue does not require user interaction.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: no · Technical impact: total

  3. Record last updated

Affected versions

  • Adobe Adobe Commerce

    through 2.4.4-p6

  • magento/community-editionPackagist

    2.4.6

  • magento/community-editionPackagist

    2.4.5

  • magento/community-editionPackagist

    2.4.4

  • magento/community-editionPackagist

    From 2.4.6-p1 · fixed in 2.4.6-p4

  • magento/community-editionPackagist

    From 2.4.5-p1 · fixed in 2.4.5-p6

  • magento/community-editionPackagist

    From 2.4.4-p1 · fixed in 2.4.4-p7

  • magento/project-community-editionPackagist

    through 2.0.2

References 1

helpx.adobe.com