CVE-2024-20719GHSA-264G-F7V8-Q5QQ
[Adobe Commerce] Stored XSS from low privileged admin user on every admin page, bypassing CVE-2023-29297
- Published
- Last modified
- Where the record stands: published, rejected by its publisher, or superseded by another id.What do these mean? →
- published
- Whether CISA lists it in its Known Exploited Vulnerabilities catalog: proof that attackers are using it.What do these mean? →
- Not listed in CISA KEV
- Fix
- Fixed in 2.4.6-p4, 2.4.5-p6, 2.4.4-p7
- Whether working attack code is public (Exploit-DB, Metasploit, Nuclei or GitHub). Public code makes attacks easier.What do these mean? →
- None on Exploit-DB, Metasploit or GitHub
CISA's decision points: whether it is exploited, whether attacks can be automated, and how much control an attacker gets. Assessed (SSVC 2.0.3).What do these mean? →
- Exploitation: none
- Automatable: no
- Technical impact: total
Summary
Adobe Commerce versions 2.4.6-p3, 2.4.5-p5, 2.4.4-p6 and earlier are affected by a stored Cross-Site Scripting (XSS) vulnerability that could be abused by an admin attacker to inject malicious scripts into every admin page. Malicious JavaScript may be executed in a victim’s browser when they browse to the page containing the vulnerable field, that could be leveraged to gain admin access.
Timeline
- CVE published
- CISA SSVC assessment
Exploitation: none · Automatable: no · Technical impact: total
- Record last updated
Affected versions
- Adobe Adobe Commerce
through 2.4.4-p6
- magento/community-editionPackagist
2.4.6
- magento/community-editionPackagist
2.4.5
- magento/community-editionPackagist
2.4.4
- magento/community-editionPackagist
From 2.4.6-p1 · fixed in 2.4.6-p4
- magento/community-editionPackagist
From 2.4.5-p1 · fixed in 2.4.5-p6
- magento/community-editionPackagist
From 2.4.4-p1 · fixed in 2.4.4-p7
- magento/project-community-editionPackagist
through 2.0.2