Skip to main content
← All vulnerabilities
CVE-2024-13280DRUPAL-CONTRIB-2024-044

Persistent Login - Moderately critical - Access bypass - SA-CONTRIB-2024-044

Published
Last modified
published
Not listed in CISA KEV
Fix
Fixed in 1.8.0, 2.2.2, 2.1.0, 2.2.0
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: none
  • Automatable: yes
  • Technical impact: total

Summary

Insufficient Session Expiration vulnerability in Drupal Persistent Login allows Forceful Browsing.This issue affects Persistent Login: from 0.0.0 before 1.8.0, from 2.0.* before 2.2.2.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: none · Automatable: yes · Technical impact: total

  3. Record last updated

Affected versions

  • Drupal Persistent Login

    From 0.0.0 · fixed in 1.8.0; fixed in 2.2.2

  • drupal/persistent_loginPackagist

    fixed in 1.8.0; From 2.2.0 · fixed in 2.2.2; From 2.0.0 · fixed in 2.1.0; From 2.1.0 · fixed in 2.2.0

References 1

drupal.org