Skip to main content
← All vulnerabilities
CVE-2024-13129

Roxy-WI roxy.py action_service os command injection

Published
Last modified
published
Not listed in CISA KEV
Fix
Fix or patch referenced
None on Exploit-DB, Metasploit or GitHub
  • Exploitation: poc
  • Automatable: no
  • Technical impact: total

Summary

A vulnerability was found in Roxy-WI up to 8.1.3. It has been declared as critical. Affected by this vulnerability is the function action_service of the file app/modules/roxywi/roxy.py. The manipulation of the argument action/service leads to os command injection. The attack can be launched remotely. The exploit has been disclosed to the public and may be used. Upgrading to version 8.1.4 is able to address this issue. The identifier of the patch is 32313928eb9ce906887b8a30bf7b9a3d5c0de1be. It is recommended to upgrade the affected component.

Timeline

  1. CVE published
  2. CISA SSVC assessment

    Exploitation: poc · Automatable: no · Technical impact: total

  3. Record last updated
  4. EPSS reached 10%

    FIRST estimates at least a 10% chance of exploitation in the next 30 days

Affected versions

  • n/a Roxy-WI

    8.1.0, 8.1.1, 8.1.2, 8.1.3

References 8

vuldb.com

GitHub · roxy-wi/roxy-wi

GitHub · 0xs1ash/Exploits